Схематическая структура корпоративной сети. Распределение IP адресации и настройка работоспособности корпоративной сети в программе CISCO PACKET TRACER, страница 16

interface Tunnel2

ip address 20.20.1.3 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp authentication nhrppass

ip nhrp map 20.20.1.1 192.168.5.1

ip nhrp map multicast 192.168.5.1

ip nhrp network-id 111

 ip nhrp nhs 20.20.1.1

ip nhrp registration no-unique

tunnel source FastEthernet1/0

tunnel destination 192.168.5.1

tunnel key 111

tunnel protection ipsec profile DMVPN

!

interface Loopback1

ip address 10.10.3.3 255.255.255.0

!

interface FastEthernet0/0

ip address 192.168.0.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 192.168.4.1 255.255.255.0

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

network 192.168.0.0 0.0.0.255 area 0

 network 192.168.1.0 0.0.0.255 area 0

network 192.168.4.0 0.0.0.255 area 0

!

router eigrp 1

network 10.10.3.0 0.0.0.255

network 20.20.0.0 0.0.0.255

network 20.20.1.0 0.0.0.255

no auto-summary

МаршрутизаторR3

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip cef

!

no ip domain lookup

!

!

!

!

crypto isakmp policy 20

authentication pre-share

crypto isakmp key 123 address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set DMVPN-TR esp-des esp-md5-hmac

mode transport

!

crypto ipsec profile DMVPN

set transform-set DMVPN-TR

!

interface Tunnel1

ip address 20.20.0.3 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp authentication nhrppass

ip nhrp map 20.20.0.1 192.168.0.1

ip nhrp map multicast 192.168.0.1

ip nhrp network-id 999

ip nhrp nhs 20.20.0.1

ip nhrp registration no-unique

tunnel source FastEthernet0/0

tunnel destination 192.168.0.1

tunnel key 999

tunnel protection ipsec profile DMVPN

!

interface Tunnel2

 ip address 20.20.1.4 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp authentication nhrppass

ip nhrp map 20.20.1.1 192.168.5.1

ip nhrp map multicast 192.168.5.1

ip nhrp network-id 111

ip nhrp nhs 20.20.1.1

ip nhrp registration no-unique

tunnel source FastEthernet0/1

tunnel destination 192.168.5.1

tunnel key 111

tunnel protection ipsec profile DMVPN

!

interface Loopback1

ip address 10.10.4.3 255.255.255.0

!

!

!

!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

!

router ospf 1

log-adjacency-changes

network 192.168.2.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0

!

!

router eigrp 1

network 10.10.4.0 0.0.0.255

network 20.20.0.0 0.0.0.255

network 20.20.1.0 0.0.0.255

no auto-summary

МаршрутизаторR4

hostname R4

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

!

!

!

crypto isakmp policy 20

authentication pre-share

crypto isakmp key 123 address 0.0.0.0 0.0.0.0

!

!

crypto ipsec transform-set DMVPN-TR esp-des esp-md5-hmac

mode transport

!

crypto ipsec profile DMVPN

set transform-set DMVPN-TR

!

!

interface Tunnel1

ip address 20.20.0.4 255.255.255.0

no ip redirects

ip mtu 1416

ip nhrp authentication nhrppass

ip nhrp map 20.20.0.1 192.168.0.1

ip nhrp map multicast 192.168.0.1

ip nhrp network-id 999

ip nhrp nhs 20.20.0.1

ip nhrp registration no-unique

tunnel source FastEthernet0/0

tunnel destination 192.168.0.1

tunnel key 999

tunnel protection ipsec profile DMVPN

!

!

interface Tunnel2

bandwidth 1000

ip address 20.20.1.1 255.255.255.0

no ip redirects

ip mtu 1416

ip hold-time eigrp 1 35

no ip next-hop-self eigrp 1

ip nhrp authentication nhrppass

ip nhrp map multicast dynamic

ip nhrp network-id 111

no ip split-horizon eigrp 1

tunnel source FastEthernet0/0